What Web Browsers are Compatible?

Question:

What Web Browsers are compatible?

Answer:

The Observer software supports the following web browsers for the HTML5 media player:

  • Google Chrome

  • Microsoft Edge

  • Mozilla Firefox

  • Apple Safari (Mac version only)

The Observer software supports the following web browser for the ActiveX media player:

  • Microsoft Internet Explorer 11 (64-bit version is recommended and installation of the plugin is required to be perform by an Administrator of your computer)  Please also look at this article for best practices for Internet Explorer.

Keywords:

Volicon Observer Compatible Web Browser Google Chrome Microsoft Edge Mozilla Firefox Apple Safari Internet Explorer HTML5 ActiveX

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.